
Add Files Command: Edit Menu
The Add Files command [Alt+E, A] or [Ctrl +A] lets you add one or more files to an existing TAR file. The 
Add Files dialog box is opened where the files can be selected.

Note: Once you create a TAR file, then close and reopen it, you cannot add files to it.

Related topic
How Do I Modify a TAR File?

Return to Command Reference



Add Files Dialog Box
The Add Files dialog lets you select files to add to the new TAR file.

Dialog box options:
File Name

Enter the name of the file you wish to add or select it from the list box below.

List Files as Type
Select the type of file to display in the list box..

Directories
Select the directory where the file is stored. If necessary, select a different drive from the Drive 
drop-down list before selecting the directory.

Drives
Select the drive where the file is stored.



Arrange Icons Command: Window Menu
The Arrange Icons command [Alt+W, I] causes all minimized window icons to be lined up at the bottom of 
the TAR/Compress Utility window.

Return to Command Reference



Cascade Command: Window Menu
The Cascade command [Alt+W, C] rearranges windows so the title bars of all open windows are visible in 
the TAR/Compress Utility window.

Related topic
Tile Command

Return to Command Reference



Close All Command: Window Menu
The Close All command [Alt+W, A] closes all open and minimized windows, with the exception of the 
TAR/Compress Utility window, which remains open.

Return to Command Reference



Command Reference
File Menu

New TAR 
Open TAR
Save TAR
Save TAR As
Extract Files
Compress File
Expand File
Exit

Edit Menu
Add Files
Delete Files
Select All
Deselect All

Options Menu
Preferences
Toolbar
Status Line

Window Menu
Cascade Command
Tile Command
Arrange Icons Command
Close All Command



Compress File Command: File Menu
The Compress File command [Alt+F, C] reduces the size of an individual file so it can be sent across the 
Internet more quickly saving you time and connect charges. The Compress File dialog box lets you select 
the file to compress.

Note: The TAR/Compress Utility supports up to 12 bit compression.

Related topics
How Do I Compress a File?
Expand File Command

Return to Command Reference



Compress File Dialog Box
Use the Compress File dialog to select the file you want to compress.

Dialog box options:
File Name

Enter the name of the file you wish to compress.

List Files as Type
Select the type of file to display in the list box above.

Directories
Select the directory where the file is stored. If necessary, select a different drive from the Drive 
drop-down list before selecting the directory.

Drives
Select the drive where the file is stored.
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Delete Files Command: Edit Menu
The Delete Files command [Alt+E, D] or [Del] lets you remove one or more selected files from an existing 
TAR file.

Note: Once you create a TAR file, then close and reopen it, you cannot remove files from it with the 
Delete command.

Related topic
How Do I Modify a TAR File?

Return to Command Reference



Deselect All Command: Edit Menu
The Deselect All command [Alt+E, E] cancels the selection of all selected files in the TAR list window.

Return to Command Reference



Exit Command: File Menu
The Exit command [Alt+F, X] or [Ctrl +F4] closes the TAR/Compress Utility window.

Return to Command Reference



Expand File Command: File Menu
The Expand File command [Alt+F, P] returns a compressed file to its original state. The Expand File 
dialog box appears where you can select the compressed file.

Note: The TAR/Compress Utility can expand files compressed with up to 12 bit compression.

Related topics
How Do I Expand a Compressed File?
Compress File Command

Return to Command Reference



Expand File Dialog Box
The Expand File dialog displays the options needed to select the compressed file you want to extract.

Dialog box options:
File Name

Enter the name of the file you wish to extract or select it from the list box.

List Files as Type
Select the type of file to display in the list box above.

Directories
Select the directory where the file is stored. If necessary, select a different drive from the Drive 
drop-down list before selecting the directory.

Drives
Select the drive where the file is stored.



Expanded File As Dialog Box
The Expanded File As dialog displays the options needed to name and save a file after you expand it.

Dialog box options:
File Name

Enter a name and optionally an extension for the expanded file you wish to save.

Save Files as Type
Select the type of file you are saving.

Directories
Select the directory where you want the file to be stored. If necessary, select a different drive from
the Drive drop-down list before selecting the directory.

Drives
Select the drive where you want the file to be stored.



Extract Files Command: File Menu
The Extract Files command [Alt+F, E] or [Ctrl +E] unpacks and copies one or more of the files from the 
single TAR file. The Extract Files dialog box opens where you can specify the destination and options.

Related topics
How Do I Extract Files from a TAR File?
New Tar Command

Return to Command Reference



Extract Files Dialog Box
The Extract Files dialog displays the options needed to copy files from a TAR file.

Dialog box options:
Extract To

Enter the destination for the extracted files. You can use the Extract To text box to enter the name
of an existing directory, or enter a new directory that you want to create. If you select the 
destination in the Directories list box, it is shown in the Extract To text box.

Directories
Select the directory where you want the file to be stored. If necessary, select a different drive from
the Drive drop-down list before selecting the directory.

Drives
Select the drive where you want the file to be stored.

Files
Choose the Selected Files option if you want to extract the files you have selected in the 
TAR/Compress window. Choose All Files if you want to disregard any selections and extract all 
files from the TAR file.

Overwrite Existing Files
Causes files in the destination directory to be overwritten by files of the same name that you 
extract from the TAR file.

Use Directory Names
Causes files to be extracted to the destination with their original directory paths. 



How Do I Compress a File?
You can compress a TAR file or any other file you plan on sending via the Internet in order to make it 
smaller. A smaller file is sent and received more quickly.

To compress a file:
1. Click the Compress button on the toolbar or pull down the File menu and select Compress File.

The Compress File dialog box opens where you can select the file.

2. Select the file in the File Name list box and choose OK. 

The file you selected is compressed. 

Note:    To conform to UNIX conventions, the last letter in the file's extension changes to Z by default. For 
example, if you compress a file named EXAMPLE which has no extension, it is saved as 
EXAMPLE.Z. If you compress a file named EXAMPLE.TAR, it is saved as EXAMPLE.TAZ.

Return to How Do I ...?



How Do I Create a New TAR File?
If you want to combine two or more files into a single file to send across the Internet, create a new TAR 
file which includes all the files you want to send.

To create a new TAR file:
1. Click the New button on the toolbar or pull down the File menu and select New TAR. A new 

window opens where the contents of the TAR file will appear.

2. Click the Add button on the toolbar or pull down the Edit menu and select Add Files. The Add 
Files dialog box opens where you can select the files to include in the TAR file.

3. Select each file in the File Name list box and choose OK. The files you select appear in the TAR 
window.

4. Repeat steps 2 and 3 to add all the files you want to include in the TAR file.

5. Click the Save button on the toolbar or pull down the File menu and select Save TAR. The Save 
TAR As dialog box opens where you can specify the name for the TAR file.

6. Enter a name for the file in the File Name text box and choose OK.

The file is saved and the filename appears in the window title bar. 

Return to How Do I ...?



How Do I Expand a Compressed File?
When you receive a compressed file, you will need to expand it before you can work with it.

To expand a file in the TAR/Compress Utility window:
1. Click the Expand button on the toolbar or pull down the File menu and select Expand File.

The Expand File dialog box appears where you can select the file.

2. Select the compressed file in the File Name list box and choose OK. 

The Expanded File As dialog box opens where you can specify the name for the file. The original 
name of the file appears in the File Name text box.

3. Enter a new name for the file or accept the one shown and choose OK. The compressed file 
expands to its original state.

If the expanded file is a TAR file (it will have a .TAR extension when you expand it), you will also have to 
extract the files from it in order to work with them.

Return to How Do I ...?



How Do I Extract Files from a TAR File?
When you receive a TAR file, you will need to extract the files from it before you can work with them.

To extract files in the TAR/Compress Utility window:
1. Click the Open button in the toolbar or pull down the File menu and select Open TAR. 

The Open TAR dialog box appears where you can select the file.

2. Select the TAR file in the File Name list box and choose OK. The contents of the TAR file appear 
in the window.

3. Select one or more files from the list.

4. Click the Extract button in the toolbar or pull down the File menu and select Extract Files. The 
Extract Files dialog box appears where you can specify the destination and options.

5. Select the destination in the Directories list box or enter the destination in the Extract To text box.

6. Check the Use Directory Names option if you want to extract the files with their original directory 
structure.

7. Choose whether to extract either the files you selected or all the files in the TAR file. If you 
previously selected all the files in the TAR/Compress Utility window, the All Files option will be 
selected by default.

8. Check the Overwrite Existing Files box if you do not want to be prompted before overwriting 
existing files.

9. Click the Extract button to extract all the files to the destination.

Return to How Do I ...?



How Do I Modify a TAR File?
While the TAR file is still open, you can modify it by adding additional files or removing files, and then 
either save it under the same filename or give it another name.

Note: Once you create a TAR file, then close and reopen it, you cannot add or remove files.

To add additional files:
1. Click the Add button on the toolbar or pull down the Edit menu and select Add Files. The Add 

Files dialog box opens where you can select the files to include in the TAR file.

2. Select each file in the File Name list box and choose OK. The files you select appear in the TAR 
window.

3. Repeat steps 2 and 3 to add all the files you want to include in the TAR file.

4. Click the Save button on the toolbar or pull down the File menu and select Save TAR. The Save 
TAR As dialog box opens where you can specify the name for the TAR file.

5. Enter a name for the file in the File Name text box and choose OK.

The file is saved and the filename appears in the window title bar.

To remove files from the TAR file:
1. Select the files to remove in the file list.

2. Click the Delete button on the toolbar or pull down the Edit menu and select Delete Files. 

The file is deleted from the TAR file only. The source file is not deleted from your hard disk.

3. Click the Save button on the toolbar or pull down the File menu and select Save TAR to save this 
modified version of the TAR file.

Tip: To save the modified TAR file with a new filename choose Save TAR As from the File menu.

Return to How Do I ...?



How Do I...
The topics below will help you get started using the TAR/Compress Utility. Just follow the step-by-step 
directions.

Create a New TAR File?
Modify a TAR File?
Extract Files from a TAR File?
Compress a File?
Expand a Compressed File?



Internet File Utilities
There are three utilities routinely used by people working on UNIX based systems when they send files 
via the Internet: 

Uuencode (and Uudecode)
Uuencode converts a binary file to an ASCII file. Only files in ASCII format can be sent via Internet e-mail, 
so binary files must be uuencoded before they can be sent. Uudecode converts an ASCII file back to a 
binary file once it is received.
Note: The Message Center automatically converts binary files to ASCII files when you attach them to 

messages and converts ASCII files back to binary files when you detach them from messages. 
You do not have to take any additional steps to convert files once you attach or detach them.

TAR
TAR combines two or more files into one compacted file which can be sent across the Internet more 
conveniently. You can access and use all the files in a TAR file you receive by extracting them with the 
TAR/Compress Utility application.

Compress
Compress reduces the size of an individual file so it can be sent across the Internet more quickly. You can
restore a compressed file to its original size by expanding it with the TAR/Compress Utility application.
Tip: Before you send a TAR file you have created you can also compress it to reduce its size. 

Note: If you are sending files to and receiving files from others who work on DOS based systems and 
generally exchange files in ZIP format, you can continue exchanging ZIP files by attaching them 
to messages. You will only need to use the TAR/Compress Utility application to exchange files 
with others working on UNIX based systems. You can of course use TAR/Compress for the 
convenience it offers you in compacting and compressing files, even if you are exchanging files 
with others on DOS based PCs if they also have QMC or access to TAR and Compress utilities.



New TAR Command: File Menu
The New TAR command [Alt+F, N] or [Ctrl +N] lets you create and name a new TAR file. A TAR file is a 
compacted file consisting of two or more individual files. When you choose New TAR, the TAR file list 
window opens where the files you add will be displayed. Use the Add Files command to select the files to 
add to the new TAR file.

Related topics
How Do I Create a New TAR File?
Extract Files Command

Return to Command Reference



Open TAR Command: File Menu
The Open TAR command [Alt+F, O] displays the contents of the selected TAR file so that you can view 
the file list. The Open TAR dialog box displays where you can select the TAR file to open. A file contents 
list for the selected TAR file is then displayed in the TAR/Compress Utility window.

Return to Command Reference



Open TAR Dialog Box
The Open TAR dialog lets you select an existing TAR file so you can view its contents and extract files 
from it.

Dialog box options:
File Name

Enter the name of the file you wish to open.

List Files as Type
Select the type of file to display in the list box above.

Directories
Select the directory where the file is stored. If necessary, select a different drive from the Drive 
drop-down list before selecting the directory.

Drives
Select the drive where the file is stored.



Preferences Command: Options Menu
The Preferences command [Alt+O, P] or [F3] opens the Preferences dialog box where you can select 
from several options which are applied to TAR files.

Return to Command Reference



Preferences Dialog Box
The options in the Preferences dialog box let you automatically apply compression or decompression to 
files included in a TAR file.

Dialog box options:
Compress Files Added to TAR File

When you create a new TAR file, each file that you add to it is automatically compressed. 

Decompress Files in TAR with .Z Extension
When you extract files from a TAR file, each file that you extract, which has a .Z extension, is 
automatically decompressed when it is extracted.



Save Compressed File As Dialog Box
The Compressed File As dialog displays the options needed to name and save the compressed file.

Dialog box options:
File Name

Enter a name and optionally an extension for the file you wish to save.

Save Files as Type
Select the type of file you are saving.

Directories
Select the directory where you want the file to be stored. If necessary, select a different drive from
the Drive drop-down list before selecting the directory.

Drives
Select the drive where you want the file to be stored.



Save TAR As Command: File Menu
The Save TAR As command [Alt+F, A] saves the TAR file with a new filename. You can specify the 
filename and directory location for the file in the Save TAR As dialog box.

Return to Command Reference



Save TAR As Dialog Box
The Save TAR As dialog displays the options needed to name and save the new TAR file.

Dialog box options:
File Name

Enter a name and optionally an extension for the file you wish to save.

Save Files as Type
Select the type of file you are saving.

Directories
Select the directory where you want the file to be stored. If necessary, select a different drive from
the Drive drop-down list before selecting the directory.

Drives
Select the drive where you want the file to be stored.



Save TAR Command: File Menu
The Save TAR command [Alt+F, S] or [Ctrl +S] saves any changes made to the TAR file, using the current
filename. If you are saving a new TAR file, the Save TAR As dialog box opens where you can specify the 
filename and directory location.

Return to Command Reference



Select All Command: Edit Menu
The Select All command [Alt+E, S] selects all the files in the current window so they can be extracted or 
deleted from the TAR file.

Related topics
How Do I Extract Files from a TAR File?
How Do I Modify a TAR File?

Return to Command Reference



Status Line Command: Options Menu
The Status Line command [Alt+O, S] toggles the display of the status line at the bottom of the 
TAR/Compress Utility window. The status line shows the number of files in the current TAR file and the 
total size of those files. It also shows the number and size of the selected files.

Return to Command Reference



TAR File List
The file list in the TAR/Compress Utility window serves two purposes:

As you create a new TAR file, the individual files you add to it are displayed in the list.
When you receive a TAR file, you can open it in order to see a list of the files it contains. 

You can use any of the following methods to select files in the list to delete or extract.

To select a file:
Click it in the file list. 

To select all the files in the list:
Pull down the Edit menu and select Select All.

To select several contiguous files in the list:
1. Click the first file you want to select. 

2. Press Shift and click the last file you want to select. 

To select several non-contiguous files in the list:
1. Click the first file you want to select. 

2. Press Ctrl and click each additional file. 

To deselect a file:
Press Ctrl and click the selected file.

To deselect all selected files:
Click a single file in the list.
or
Pull down the Edit menu and select Deselect All.



TAR/Compress Utility Overview
The TAR/Compress Utility window displays the tools which let you:

Combine two or more files you want to send via the Internet into a new TAR file.
Extract files from a TAR file you have received from someone.
Compress a file to reduce its size before you send it.
Expand a compressed file you have received to its original state so you can use it.

The TAR/Compress Utility application includes some QMC features. You can:
Toggle the display of the toolbar and status line with commands on the Options menu.
Specify default options for TAR and Compress with the Preferences command. 
Open and arrange multiple windows.

Related topics
Internet File Utilities
TAR/Compress Utility Window
TAR File List



TAR/Compress Utility Window
The TAR/Compress Utility window lets you view the contents of TAR files so you can work with them. It 
includes:

A menu bar for accessing commands.
A toolbar with buttons so you have instant access to the commands you need.
A list of all the files in the new or open TAR file.
A status line that provides information about the files in the window.



Tile Command: Window Menu
The Tile command [Alt+W, T] rearranges windows so they are all visible in the TAR/Compress Utility 
window.

Related topic
Cascade Command

Return to Command Reference



Toolbar Command: Options Menu
The Toolbar command [Alt+O, T] toggles the display of the toolbar in the TAR/Compress Utility window. 
Click on any tool to jump to the associated command information.

As in Quarterdeck Mosaic, you can move the toolbar in this window. Although the toolbar is initially 
displayed below the menu bar, you don't have to leave it there. You can turn it into a floating toolbar and 
change its shape.

To move the toolbar:
1. Place the mouse cursor in the blank area between the tools in the toolbar and the program icon. 

You'll see the hand cursor.

2. Drag the toolbar to the extreme bottom, left or right of the application window and release the 
mouse button. The toolbar will move to the new location.

or

Drag the toolbar to any area within the application window except the extreme bottom, left, or 
right and release the mouse button. The toolbar will move to the new location and become a 
floating toolbar which can be dragged around the screen.

To move the toolbar back to the top of your application window:
1. Place the mouse cursor in the blank area between the tools in the toolbar and the program icon. 

You'll see the hand cursor.

2. Drag the toolbar to the extreme top of the application window and release the mouse button.

Return to Command Reference



Troubleshooting
During installation, a Troubleshooting help file was installed in your Quarterdeck Internet program group.   
This file includes problem solving suggestions for all of the programs included with your software.

To view the file, double-click on the Troubleshooting icon in your Quarterdeck program group.






